Presto: It was my fault because Presto does it backwards

Presto stopped working for me one day because all of a sudden my balance went from "positive something" to -$97. I'm one of the 3% of people who struggled through the website to setup an "auto-load" feature. When my balance goes under $20 it's supposed to top up to $40. 

That is actually the minimum setup. You can't load less than $20, so $40 becomes the minimum "top-up" level. I'm going to guess a lot of people choose this setup - who wants to have $200 parked inside OC transpo on a regular basis?

How did my card end up at -$97? Simple: Presto engaged the auto-load system six times for me as I used my card in normal situations. You'd think it would go like this:

  • Presto: Hey, your balance is now $18.87. Time to load the donuts!
  • Presto: Hey Mastercard, got $21.13?
  • Mastercard: Damn straight!
  • Presto: Awesome.
  • Presto: Hey card, here's $21.13.
  • Card: Thanks bro!

You would be wrong. It goes like this:

  • Presto: Hey, your balance is now $18.87. Time to load the donuts!
  • Presto: Hey card, here's $21.13.
  • Card: Thanks bro!
  • Presto: Hey Mastercard, got balance?
  • Mastercard: Screw you, that card expired or otherwise funds are not available.
  • Presto: Oh noes!
  • [repeat 6 times]
  • ...
  • Presto: Hey Card, gimme $120.
  • Card: Sadface. Now my value is -$97!

I'd say that's broken.

I need to check my statement and confirm that I've actually been riding OCTranspo for free for some indeterminate amount of time. Assuming that's true I'll have to manually load money onto the card so that it has a positive balance again - only then will the auto-load start to work again.

Nobody told me this of course, so I've been tapping like an idiot for a week after setting up my new credit card.

I really want to be a Presto champion. Presto makes it hard to be one.

Tap tap!